Install MikroTik CHR on VPS

Install mikrotik chr (cloud hosted router) pada vps

  • Reinstall image vps
  • Setelah selesai reinstall, login ke vps dan cek nama disk dan nama interface ethernet pada vps
lsblk

ip a
  • Buat script installer chr.sh, versi yang di install 6.48.4 stable. Sesuaikan interface ethernet yang ada pada linux vps, bisa eth0, ens192, enp0s3, dan sesuaikan nama disk bisa sda, vda, xda. Harus sesuai, jika tidak maka akan error. Untuk password chr bisa langsung di set pada script, pada artike ini misalkan: sideka8080
nano chr.sh
#!/bin/sh
wget https://download.mikrotik.com/routeros/6.48.4/chr-6.48.4.img.zip -O chr.img.zip  && \
gunzip -c chr.img.zip > chr.img  && \
mount -o loop,offset=512 chr.img /mnt && \
ADDRESS=`ip addr show ens192 | grep global | cut -d' ' -f 6 | head -n 1` && \
GATEWAY=`ip route list | grep default | cut -d' ' -f 3` && \
echo "/ip address add address=$ADDRESS interface=[/interface ethernet find where name=ether1]
/ip route add gateway=$GATEWAY
/ip dns set servers=8.8.8.8,1.1.1.1
/ip service disable telnet
/ip service disable ssh
/ip service disable ftp
/ip service disable api
/ip service disable api-ssl
/user set 0 password=sideka8080
" > /mnt/rw/autorun.scr && \
umount /mnt && \
echo u > /proc/sysrq-trigger && \
dd if=chr.img bs=1024 of=/dev/sda && \
reboot
  • Beri permisi execute pada file chr.sh lalu jalankan script installer chr.
chmod +x chr.sh
bash chr.sh
  • Login chr dengan winbox
  • Berhasil login ke winbox, noted: Allow port 8291 protocol tcp, port 1723 protocol tcp, dan protocol GRE.
  • Jka vps mempunyai firewall terpisah.
  • Tes vpn dengan pptp server bisa konek.

herdiana3389

A system administrator with skills in system administration, virtualization, linux, windows, networking, cloud computing, container, etc.