Setting BGP Confederations Cisco – GNS3 Lab30

Setting BGP Confederations Cisco – GNS3 Lab30

  • R1 FastEthernet 0/0 : 192.168.10.1
  • R1 FastEthernet 0/1 : 192.168.20.1
  • R1 Loopback 0 : 1.1.1.1
  • R2 FastEthernet 0/0 : 192.168.10.2
  • R2 FastEthernet 1/0 : 10.10.10.1
  • R2 FastEthernet 2/0 : 30.30.30.2
  • R2 Loopback 0 : 2.2.2.2
  • R3 FastEthernet 0/1 : 192.168.20.2
  • R3 FastEthernet 1/0 : 20.20.20.2
  • R3 FastEthernet 2/0 : 30.30.30.1
  • R3 Loopback 0 : 3.3.3.3
  • R4 FastEthernet 0/0 : 192.168.30.2
  • R4 FastEthernet 1/0 : 10.10.10.2
  • R4 FastEthernet 2/0 : 40.40.40.1
  • R4 Loopback 0 : 4.4.4.4
  • R5 FastEthernet 0/1 : 192.168.40.2
  • R5 FastEthernet 1/0 : 20.20.20.1
  • R5 FastEthernet 2/0 : 40.40.40.2
  • R5 Loopback 0 : 5.5.5.5
  • R6 FastEthernet 0/0 : 192.168.30.1
  • R6 FastEthernet 0/1 : 192.168.40.1
  • R6 Loopback 0 : 6.6.6.6

Setting IP address

  • R1
R1# configure terminal
R1(config)# interface fastEthernet 0/0
R1(config-if)# ip address 192.168.10.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

R1(config)# interface fastEthernet 0/1
R1(config-if)# ip address 192.168.20.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

R1(config)# interface loopback 0
R1(config-if)# ip address 1.1.1.1 255.255.255.0
R1(config-if)# exit
  • R2
R2# configure terminal
R2(config)# interface fastEthernet 0/0
R2(config-if)# ip address 192.168.10.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# exit

R2(config)# interface fastEthernet 1/0
R2(config-if)# ip address 10.10.10.1 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# exit

R2(config)# interface fastEthernet 2/0
R2(config-if)# ip address 30.30.30.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# exit

R2(config)# interface loopback 0
R2(config-if)# ip address 2.2.2.2 255.255.255.0
R2(config-if)# exit
  • R3
R3# configure terminal
R3(config)# interface fastEthernet 0/1
R3(config-if)# ip address 192.168.20.2 255.255.255.0
R3(config-if)# no shutdown
R3(config-if)# exit

R3(config)# interface fastEthernet 1/0
R3(config-if)# ip address 20.20.20.2 255.255.255.0
R3(config-if)# no shutdown
R3(config-if)# exit

R3(config)# interface fastEthernet 2/0
R3(config-if)# ip address 30.30.30.1 255.255.255.0
R3(config-if)# no shutdown
R3(config-if)# exit

R3(config)# interface loopback 0
R3(config-if)# ip address 3.3.3.3 255.255.255.0
R3(config-if)# exit
  • R4
R4# configure terminal
R4(config)# interface fastEthernet 0/0
R4(config-if)# ip address 192.168.30.2 255.255.255.0
R4(config-if)# no shutdown
R4(config-if)# exit

R4(config)# interface fastEthernet 1/0
R4(config-if)# ip address 10.10.10.2 255.255.255.0
R4(config-if)# no shutdown
R4(config-if)# exit

R4(config)# interface fastEthernet 2/0
R4(config-if)# ip address 40.40.40.1 255.255.255.0
R4(config-if)# no shutdown
R4(config-if)# exit

R4(config)# interface loopback 0
R4(config-if)# ip address 4.4.4.4 255.255.255.0
R4(config-if)# exit
  • R5
R5# configure terminal
R5(config)# interface fastEthernet 0/1
R5(config-if)# ip address 192.168.40.2 255.255.255.0
R5(config-if)# no shutdown
R5(config-if)# exit

R5(config)# interface fastEthernet 1/0
R5(config-if)# ip address 20.20.20.1 255.255.255.0
R5(config-if)# no shutdown
R5(config-if)# exit

R5(config)# interface fastEthernet 2/0
R5(config-if)# ip address 40.40.40.2 255.255.255.0
R5(config-if)# no shutdown
R5(config-if)# exit

R5(config)# interface loopback 0
R5(config-if)# ip address 5.5.5.5 255.255.255.0
R5(config-if)# exit
  • R6
R6# configure terminal
R6(config)# interface fastEthernet 0/0
R6(config-if)# ip address 192.168.30.1 255.255.255.0
R6(config-if)# no shutdown
R6(config-if)# exit

R6(config)# interface fastEthernet 0/1
R6(config-if)# ip address 192.168.40.1 255.255.255.0
R6(config-if)# no shutdown
R6(config-if)# exit

R6(config)# interface loopback 0
R6(config-if)# ip address 6.6.6.6 255.255.255.0
R6(config-if)# exit

Setting OSPF pada AS 20, 30, 40, 50

  • R2
R2(config)# router ospf 1
R2(config-router)# network 10.10.10.0 0.0.0.255 area 0
R2(config-router)# network 30.30.30.0 0.0.0.255 area 0
R2(config-router)# network 2.2.2.0 0.0.0.255 area 0
  • R3
R3(config)# router ospf 1
R3(config-router)# network 20.20.20.0 0.0.0.255 area 0
R3(config-router)# network 30.30.30.0 0.0.0.255 area 0
R3(config-router)# network 3.3.3.0 0.0.0.255 area 0
  • R4
R4(config)# router ospf 1
R4(config-router)# network 10.10.10.0 0.0.0.255 area 0
R4(config-router)# network 40.40.40.0 0.0.0.255 area 0
R4(config-router)# network 4.4.4.0 0.0.0.255 area 0
  • R5
R5(config)#router ospf 1
R5(config-router)#network 20.20.20.0 0.0.0.255 area 0
R5(config-router)#network 40.40.40.0 0.0.0.255 area 0
R5(config-router)#network 5.5.5.0 0.0.0.255 area 0

Setting iBGP Confederation AS 2345 pada AS 20, 30, 40, 50

  • R2
R2(config)# router bgp 20
R2(config-router)# bgp confederation identifier 2345
R2(config-router)# bgp confederation peers 30 40

R2(config-router)# neighbor 3.3.3.3 remote-as 30
R2(config-router)# neighbor 3.3.3.3 update-source loopback 0
R2(config-router)# neighbor 3.3.3.3 ebgp-multihop 5
R2(config-router)# neighbor 4.4.4.4 remote-as 40
R2(config-router)# neighbor 4.4.4.4 update-source loopback 0
R2(config-router)# neighbor 4.4.4.4 ebgp-multihop 5
R2(config-router)# neighbor 192.168.10.1 remote-as 10
  • R3
R3(config)# router bgp 30
R3(config-router)# bgp confederation identifier 2345
R3(config-router)# bgp confederation peers 20 50

R3(config-router)# neighbor 2.2.2.2 remote-as 20
R3(config-router)# neighbor 2.2.2.2 update-source loopback 0
R3(config-router)# neighbor 2.2.2.2 ebgp-multihop 5
R3(config-router)# neighbor 5.5.5.5 remote-as 50
R3(config-router)# neighbor 5.5.5.5 update-source loopback 0
R3(config-router)# neighbor 5.5.5.5 ebgp-multihop 5
R3(config-router)# neighbor 192.168.20.1 remote-as 10
  • R4
R4(config)# router bgp 40
R4(config-router)# bgp confederation identifier 2345
R4(config-router)# bgp confederation peers 20 50

R4(config-router)# neighbor 2.2.2.2 remote-as 20
R4(config-router)# neighbor 2.2.2.2 update-source loopback 0
R4(config-router)# neighbor 2.2.2.2 ebgp-multihop 5
R4(config-router)# neighbor 5.5.5.5 remote-as 50
R4(config-router)# neighbor 5.5.5.5 update-source loopback 0
R4(config-router)# neighbor 5.5.5.5 ebgp-multihop 5
R4(config-router)# neighbor 192.168.30.1 remote-as 60
  • R5
R5(config)# router bgp 50
R5(config-router)# bgp confederation identifier 2345
R5(config-router)# bgp confederation peers 30 40

R5(config-router)# neighbor 3.3.3.3 remote-as 30
R5(config-router)# neighbor 3.3.3.3 update-source loopback 0
R5(config-router)# neighbor 3.3.3.3 ebgp-multihop 5
R5(config-router)# neighbor 4.4.4.4 remote-as 40
R5(config-router)# neighbor 4.4.4.4 update-source loopback 0
R5(config-router)# neighbor 4.4.4.4 ebgp-multihop 5
R5(config-router)# neighbor 192.168.40.1 remote-as 60

Setting eBGP AS 10 dan AS 60

  • R1
R1(config)# router bgp 10
R1(config-router)# neighbor 192.168.10.2 remote-as 2345
R1(config-router)# neighbor 192.168.20.2 remote-as 2345
  • R6
R6(config)# router bgp 60
R6(config-router)# neighbor 192.168.30.2 remote-as 2345
R6(config-router)# neighbor 192.168.40.2 remote-as 2345

Advertise All Loopback

  • R1
R1(config)# router bgp 10
R1(config-router)# network 1.1.1.0 mask 255.255.255.0
  • R2
R2(config)# router bgp 20
R2(config-router)# network 2.2.2.0 mask 255.255.255.0
  • R3
R3(config)# router bgp 30
R3(config-router)# network 3.3.3.0 mask 255.255.255.0
  • R4
R4(config)# router bgp 40
R4(config-router)# network 4.4.4.0 mask 255.255.255.0
  • R5
R5(config)# router bgp 50
R5(config-router)# network 5.5.5.0 mask 255.255.255.0
  • R6
R6(config)# router bgp 60
R6(config-router)# network 6.6.6.0 mask 255.255.255.0

Advertise Physical pada AS 20, 30, 40, 50

  • R2
R2(config)# router bgp 20
R2(config-router)# network 192.168.10.0 mask 255.255.255.0
R2(config-router)# network 10.10.10.0 mask 255.255.255.0
R2(config-router)# network 30.30.30.0 mask 255.255.255.0
  • R3
R3(config)# router bgp 30
R3(config-router)# network 192.168.20.0 mask 255.255.255.0
R3(config-router)# network 20.20.20.0 mask 255.255.255.0
R3(config-router)# network 30.30.30.0 mask 255.255.255.0
  • R4
R4(config)# router bgp 40
R4(config-router)# network 192.168.30.0 mask 255.255.255.0
R4(config-router)# network 10.10.10.0 mask 255.255.255.0
R4(config-router)# network 40.40.40.0 mask 255.255.255.0
  • R5
R5(config)# router bgp 50
R5(config-router)# network 192.168.40.0 mask 255.255.255.0
R5(config-router)# network 20.20.20.0 mask 255.255.255.0
R5(config-router)# network 40.40.40.0 mask 255.255.255.0

Verifikasi IP BGP

  • R1
R1# show ip bgp
BGP table version is 17, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24       0.0.0.0                  0         32768 i
*  2.2.2.0/24       192.168.20.2                           0 2345 i
*>                  192.168.10.2             0             0 2345 i
*  3.3.3.0/24       192.168.10.2                           0 2345 i
*>                  192.168.20.2             0             0 2345 i
*  4.4.4.0/24       192.168.20.2                           0 2345 i
*>                  192.168.10.2                           0 2345 i
*  5.5.5.0/24       192.168.10.2                           0 2345 i
*>                  192.168.20.2                           0 2345 i
*  6.6.6.0/24       192.168.20.2                           0 2345 60 i
*>                  192.168.10.2                           0 2345 60 i
*  10.10.10.0/24    192.168.20.2                           0 2345 i
*>                  192.168.10.2             0             0 2345 i
*  20.20.20.0/24    192.168.10.2                           0 2345 i
*>                  192.168.20.2             0             0 2345 i
*  30.30.30.0/24    192.168.20.2             0             0 2345 i
*>                  192.168.10.2             0             0 2345 i
*  40.40.40.0/24    192.168.10.2                           0 2345 i
*>                  192.168.20.2                           0 2345 i
r  192.168.10.0     192.168.20.2                           0 2345 i
r>                  192.168.10.2             0             0 2345 i
r  192.168.20.0     192.168.10.2                           0 2345 i
r>                  192.168.20.2             0             0 2345 i
*  192.168.30.0     192.168.20.2                           0 2345 i
*>                  192.168.10.2                           0 2345 i
*  192.168.40.0     192.168.10.2                           0 2345 i
*>                  192.168.20.2                           0 2345 i
  • R2
R2# show ip bgp
BGP table version is 20, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  1.1.1.0/24       192.168.20.1             0    100      0 (30) 10 i
*>                  192.168.10.1             0             0 10 i
*> 2.2.2.0/24       0.0.0.0                  0         32768 i
*> 3.3.3.0/24       3.3.3.3                  0    100      0 (30) i
*> 4.4.4.0/24       4.4.4.4                  0    100      0 (40) i
*> 5.5.5.0/24       5.5.5.5                  0    100      0 (30 50) i
*  6.6.6.0/24       192.168.40.1             0    100      0 (30 50) 60 i
*>                  192.168.30.1             0    100      0 (40) 60 i
*  10.10.10.0/24    4.4.4.4                  0    100      0 (40) i
*>                  0.0.0.0                  0         32768 i
r  20.20.20.0/24    5.5.5.5                  0    100      0 (40 50) i
r>                  3.3.3.3                  0    100      0 (30) i
*  30.30.30.0/24    3.3.3.3                  0    100      0 (30) i
*>                  0.0.0.0                  0         32768 i
r  40.40.40.0/24    5.5.5.5                  0    100      0 (30 50) i
r>                  4.4.4.4                  0    100      0 (40) i
*> 192.168.10.0     0.0.0.0                  0         32768 i
*> 192.168.20.0     3.3.3.3                  0    100      0 (30) i
*> 192.168.30.0     4.4.4.4                  0    100      0 (40) i
*> 192.168.40.0     5.5.5.5                  0    100      0 (30 50) i
  • R3
R3# show ip bgp
BGP table version is 22, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  1.1.1.0/24       192.168.10.1             0    100      0 (20) 10 i
*>                  192.168.20.1             0             0 10 i
*> 2.2.2.0/24       2.2.2.2                  0    100      0 (20) i
*> 3.3.3.0/24       0.0.0.0                  0         32768 i
*> 4.4.4.0/24       4.4.4.4                  0    100      0 (20 40) i
*> 5.5.5.0/24       5.5.5.5                  0    100      0 (50) i
*  6.6.6.0/24       192.168.30.1             0    100      0 (20 40) 60 i
*>                  192.168.40.1             0    100      0 (50) 60 i
r  10.10.10.0/24    4.4.4.4                  0    100      0 (50 40) i
r>                  2.2.2.2                  0    100      0 (20) i
*  20.20.20.0/24    5.5.5.5                  0    100      0 (50) i
*>                  0.0.0.0                  0         32768 i
*> 30.30.30.0/24    0.0.0.0                  0         32768 i
*                   2.2.2.2                  0    100      0 (20) i
r  40.40.40.0/24    4.4.4.4                  0    100      0 (20 40) i
r>                  5.5.5.5                  0    100      0 (50) i
*> 192.168.10.0     2.2.2.2                  0    100      0 (20) i
*> 192.168.20.0     0.0.0.0                  0         32768 i
*> 192.168.30.0     4.4.4.4                  0    100      0 (20 40) i
*> 192.168.40.0     5.5.5.5                  0    100      0 (50) i
  • R4
R4# show ip bgp
BGP table version is 22, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  1.1.1.0/24       192.168.20.1             0    100      0 (50 30) 10 i
*>                  192.168.10.1             0    100      0 (20) 10 i
*  2.2.2.0/24       2.2.2.2                  0    100      0 (50 30 20) i
*>                  2.2.2.2                  0    100      0 (20) i
*  3.3.3.0/24       3.3.3.3                  0    100      0 (50 30) i
*>                  3.3.3.3                  0    100      0 (20 30) i
*> 4.4.4.0/24       0.0.0.0                  0         32768 i
*> 5.5.5.0/24       5.5.5.5                  0    100      0 (20 30 50) i
*                   5.5.5.5                  0    100      0 (50) i
*  6.6.6.0/24       192.168.40.1             0    100      0 (50) 60 i
*>                  192.168.30.1             0             0 60 i
*> 10.10.10.0/24    0.0.0.0                  0         32768 i
*                   2.2.2.2                  0    100      0 (20) i
r> 20.20.20.0/24    5.5.5.5                  0    100      0 (50) i
r                   3.3.3.3                  0    100      0 (20 30) i
r  30.30.30.0/24    3.3.3.3                  0    100      0 (50 30) i
r>                  2.2.2.2                  0    100      0 (20) i
*  40.40.40.0/24    5.5.5.5                  0    100      0 (50) i
*>                  0.0.0.0                  0         32768 i
*  192.168.10.0     2.2.2.2                  0    100      0 (50 30 20) i
*>                  2.2.2.2                  0    100      0 (20) i
*  192.168.20.0     3.3.3.3                  0    100      0 (50 30) i
*>                  3.3.3.3                  0    100      0 (20 30) i
*> 192.168.30.0     0.0.0.0                  0         32768 i
*> 192.168.40.0     5.5.5.5                  0    100      0 (20 30 50) i
*                   5.5.5.5                  0    100      0 (50) i
  • R5
R5# show ip bgp
BGP table version is 26, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  1.1.1.0/24       192.168.10.1             0    100      0 (40 20) 10 i
*>                  192.168.20.1             0    100      0 (30) 10 i
*  2.2.2.0/24       2.2.2.2                  0    100      0 (40 20) i
*>                  2.2.2.2                  0    100      0 (30 20) i
*  3.3.3.0/24       3.3.3.3                  0    100      0 (40 20 30) i
*>                  3.3.3.3                  0    100      0 (30) i
*> 4.4.4.0/24       4.4.4.4                  0    100      0 (30 20 40) i
*                   4.4.4.4                  0    100      0 (40) i
*> 5.5.5.0/24       0.0.0.0                  0         32768 i
*  6.6.6.0/24       192.168.30.1             0    100      0 (40) 60 i
*>                  192.168.40.1             0             0 60 i
r> 10.10.10.0/24    4.4.4.4                  0    100      0 (40) i
r                   2.2.2.2                  0    100      0 (30 20) i
*> 20.20.20.0/24    0.0.0.0                  0         32768 i
*                   3.3.3.3                  0    100      0 (30) i
r  30.30.30.0/24    2.2.2.2                  0    100      0 (40 20) i
r>                  3.3.3.3                  0    100      0 (30) i
*> 40.40.40.0/24    0.0.0.0                  0         32768 i
*                   4.4.4.4                  0    100      0 (40) i
*  192.168.10.0     2.2.2.2                  0    100      0 (40 20) i
*>                  2.2.2.2                  0    100      0 (30 20) i
*  192.168.20.0     3.3.3.3                  0    100      0 (40 20 30) i
*>                  3.3.3.3                  0    100      0 (30) i
*> 192.168.30.0     4.4.4.4                  0    100      0 (30 20 40) i
*                   4.4.4.4                  0    100      0 (40) i
*> 192.168.40.0     0.0.0.0                  0         32768 i
  • R6
R6# show ip bgp
BGP table version is 19, local router ID is 6.6.6.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  1.1.1.0/24       192.168.40.2                           0 2345 10 i
*>                  192.168.30.2                           0 2345 10 i
*  2.2.2.0/24       192.168.40.2                           0 2345 i
*>                  192.168.30.2                           0 2345 i
*  3.3.3.0/24       192.168.40.2                           0 2345 i
*>                  192.168.30.2                           0 2345 i
*  4.4.4.0/24       192.168.40.2                           0 2345 i
*>                  192.168.30.2             0             0 2345 i
*  5.5.5.0/24       192.168.30.2                           0 2345 i
*>                  192.168.40.2             0             0 2345 i
*> 6.6.6.0/24       0.0.0.0                  0         32768 i
*  10.10.10.0/24    192.168.40.2                           0 2345 i
*>                  192.168.30.2             0             0 2345 i
*  20.20.20.0/24    192.168.30.2                           0 2345 i
*>                  192.168.40.2             0             0 2345 i
*  30.30.30.0/24    192.168.40.2                           0 2345 i
*>                  192.168.30.2                           0 2345 i
*  40.40.40.0/24    192.168.40.2             0             0 2345 i
*>                  192.168.30.2             0             0 2345 i
*  192.168.10.0     192.168.40.2                           0 2345 i
*>                  192.168.30.2                           0 2345 i
*  192.168.20.0     192.168.30.2                           0 2345 i
*>                  192.168.40.2                           0 2345 i
r  192.168.30.0     192.168.40.2                           0 2345 i
r>                  192.168.30.2             0             0 2345 i
r  192.168.40.0     192.168.30.2                           0 2345 i
r>                  192.168.40.2             0             0 2345 i

Verifikasi Routing Table

  • R1
R1# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     2.0.0.0/24 is subnetted, 1 subnets
B       2.2.2.0 [20/0] via 192.168.10.2, 00:28:06
     3.0.0.0/24 is subnetted, 1 subnets
B       3.3.3.0 [20/0] via 192.168.20.2, 00:27:35
B    192.168.30.0/24 [20/0] via 192.168.10.2, 00:08:16
     4.0.0.0/24 is subnetted, 1 subnets
B       4.4.4.0 [20/0] via 192.168.10.2, 00:27:35
     20.0.0.0/24 is subnetted, 1 subnets
B       20.20.20.0 [20/0] via 192.168.20.2, 00:08:48
     5.0.0.0/24 is subnetted, 1 subnets
B       5.5.5.0 [20/0] via 192.168.20.2, 00:27:07
C    192.168.10.0/24 is directly connected, FastEthernet0/0
B    192.168.40.0/24 [20/0] via 192.168.20.2, 00:07:49
     6.0.0.0/24 is subnetted, 1 subnets
B       6.6.6.0 [20/0] via 192.168.10.2, 00:07:49
C    192.168.20.0/24 is directly connected, FastEthernet0/1
     40.0.0.0/24 is subnetted, 1 subnets
B       40.40.40.0 [20/0] via 192.168.20.2, 00:07:50
     10.0.0.0/24 is subnetted, 1 subnets
B       10.10.10.0 [20/0] via 192.168.10.2, 00:09:53
     30.0.0.0/24 is subnetted, 1 subnets
B       30.30.30.0 [20/0] via 192.168.10.2, 00:09:23
  • R2
R2# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
B       1.1.1.0 [20/0] via 192.168.10.1, 00:28:48
     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback0
     3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O       3.3.3.3/32 [110/2] via 30.30.30.1, 01:16:00, FastEthernet2/0
B       3.3.3.0/24 [200/0] via 3.3.3.3, 00:27:15
B    192.168.30.0/24 [200/0] via 4.4.4.4, 00:07:56
     4.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O       4.4.4.4/32 [110/2] via 10.10.10.2, 01:16:00, FastEthernet1/0
B       4.4.4.0/24 [200/0] via 4.4.4.4, 00:27:17
     20.0.0.0/24 is subnetted, 1 subnets
O       20.20.20.0 [110/2] via 30.30.30.1, 01:16:02, FastEthernet2/0
     5.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O       5.5.5.5/32 [110/3] via 30.30.30.1, 01:16:03, FastEthernet2/0
                   [110/3] via 10.10.10.2, 01:16:03, FastEthernet1/0
B       5.5.5.0/24 [200/0] via 5.5.5.5, 00:26:48
C    192.168.10.0/24 is directly connected, FastEthernet0/0
B    192.168.40.0/24 [200/0] via 5.5.5.5, 00:07:29
     6.0.0.0/24 is subnetted, 1 subnets
B       6.6.6.0 [200/0] via 192.168.30.1, 00:07:56
B    192.168.20.0/24 [200/0] via 3.3.3.3, 00:08:30
     40.0.0.0/24 is subnetted, 1 subnets
O       40.40.40.0 [110/2] via 10.10.10.2, 01:16:06, FastEthernet1/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet1/0
     30.0.0.0/24 is subnetted, 1 subnets
C       30.30.30.0 is directly connected, FastEthernet2/0
  • R6
R6# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
B       1.1.1.0 [20/0] via 192.168.30.2, 00:11:28
     2.0.0.0/24 is subnetted, 1 subnets
B       2.2.2.0 [20/0] via 192.168.30.2, 00:29:46
     3.0.0.0/24 is subnetted, 1 subnets
B       3.3.3.0 [20/0] via 192.168.30.2, 00:28:44
C    192.168.30.0/24 is directly connected, FastEthernet0/0
     4.0.0.0/24 is subnetted, 1 subnets
B       4.4.4.0 [20/0] via 192.168.30.2, 00:29:15
     20.0.0.0/24 is subnetted, 1 subnets
B       20.20.20.0 [20/0] via 192.168.40.2, 00:09:58
     5.0.0.0/24 is subnetted, 1 subnets
B       5.5.5.0 [20/0] via 192.168.40.2, 00:28:46
B    192.168.10.0/24 [20/0] via 192.168.30.2, 00:12:01
C    192.168.40.0/24 is directly connected, FastEthernet0/1
     6.0.0.0/24 is subnetted, 1 subnets
C       6.6.6.0 is directly connected, Loopback0
B    192.168.20.0/24 [20/0] via 192.168.40.2, 00:10:00
     40.0.0.0/24 is subnetted, 1 subnets
B       40.40.40.0 [20/0] via 192.168.30.2, 00:09:30
     10.0.0.0/24 is subnetted, 1 subnets
B       10.10.10.0 [20/0] via 192.168.30.2, 00:11:01
     30.0.0.0/24 is subnetted, 1 subnets
B       30.30.30.0 [20/0] via 192.168.30.2, 00:10:31

Pengujian

  • R1
R1# ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/28/48 ms

R1# ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/26/36 ms

R1# ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/61/84 ms

R1# ping 5.5.5.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/63/72 ms

R1# ping 6.6.6.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/90/96 ms
  • R6
R6# ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 76/87/96 ms

R6# ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/60/68 ms

R6# ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 76/88/108 ms

R6# ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/28/40 ms

R6# ping 5.5.5.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/31/44 ms

herdiana3389

A system administrator with skills in system administration, virtualization, linux, windows, networking, cloud computing, container, etc.