Setting Cisco Internet Gateway – GNS3 Lab5

Setting Cisco Internet Gateway – GNS3 Lab5

  • Router Cisco 3660 > download disini
  • FastEthernet 0/0 : 192.168.249.10 (mengarah ke internet)
  • FastEthernet 0/1 : 192.168.10.1 (mengarah ke lan)
  • Default gateway: 192.168.249.2 , DNS: 8.8.8.8 1.1.1.1

R1 c3660

  • Setting IP address
R1# configure terminal

R1(config)# interface fastEthernet 0/0
R1(config-if)# ip address 192.168.249.10 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

R1(config)# interface fastEthernet 0/1
R1(config-if)# ip address 192.168.10.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

R1(config)# do show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.249.10  YES manual up                    up
FastEthernet0/1            192.168.10.1    YES manual up                    up
  • Setting Default Gateway (route)
R1(config)# ip route 0.0.0.0 0.0.0.0 192.168.249.2

R1(config)# do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.249.2 to network 0.0.0.0

C    192.168.10.0/24 is directly connected, FastEthernet0/1
C    192.168.249.0/24 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 192.168.249.2
  • Setting DNS resolver
R1(config)# ip domain lookup
R1(config)# ip name-server 8.8.8.8

R1(config)# do ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/54/64 ms

R1(config)# do ping sys-ops.id
Translating "sys-ops.id"...domain server (8.8.8.8) [OK]
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 103.152.118.72, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/46/64 ms
  • Setting NAT
R1(config)# access-list 1 permit 192.168.10.0 0.0.0.255
R1(config)# ip nat inside source list 1 interface fastEthernet 0/0 overload

R1(config)# interface fastEthernet 0/0
R1(config-if)# ip nat outside
R1(config-if)# exit

R1(config)# interface fastEthernet 0/1
R1(config-if)# ip nat inside
R1(config-if)# exit
R1(config)#
  • Setting DHCP Server
R1(config)# ip dhcp pool LAN
R1(dhcp-config)# network 192.168.10.0 255.255.255.0
R1(dhcp-config)# default-router 192.168.10.1
R1(dhcp-config)# dns-server 8.8.8.8 1.1.1.1
R1(dhcp-config)# domain-name sys-ops.id
R1(dhcp-config)# ip dhcp excluded-address 192.168.10.1
R1(dhcp-config)# lease infinite
R1(dhcp-config)# exit
  • Simpan setingan R1 ke dalam startup
R1# write
Building configuration...
[OK]

R1# copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Pengujian

  • Cek IP dhcp client pada vm windows-1 dan windows-2, dan test ping ke internet
  • Cek IP dhcp client pada VPCS, dan test ping ke internet
  • DHCP Server berjalan dengan baik, dan client berhasil terhubung ke internet lewat router cisco

herdiana3389

A system administrator with skills in system administration, virtualization, linux, windows, networking, cloud computing, container, etc.