Setting MPLS with VPLS MikroTik – GNS3 Lab52

Setting MPLS (Multi Protocol Label Switching) dengan VPLS (Virtual Private LAN Services) MikroTik – GNS3 Lab52

  • MikroTik-1 ether2: 10.10.10.1/24
  • MikroTik-1 ether3: 10.10.20.1/24
  • MikroTik-1 loopback: 10.0.0.1/32
  • MikroTik-2 ether2: 10.10.10.2/24
  • MikroTik-2 ether3: 192.168.1.1/24
  • MikroTik-2 loopback: 10.0.0.2/32
  • MikroTik-3 ether2: 10.10.20.2/24
  • MikroTik-3 ether3: 192.168.2.1/24
  • MikroTik-3 loopback: 10.0.0.3/32
  • MikroTik-4 ether2: 192.168.1.2/24
  • MikroTik-4 ether3: 192.168.10.1/24
  • MikroTik-4 loopback: 10.0.0.4/32
  • MikroTik-5 ether2: 192.168.2.2/24
  • MikroTik-5 ether3: 192.168.10.1/24
  • MikroTik-5 loopback: 10.0.0.5/32
  • PC1: 192.168.10.10/24
  • PC2: 192.168.10.20/24

Setting IP Address

  • MikroTik-1
/interface bridge
add name=loopback

/ip address
add address=10.0.0.1 interface=loopback network=10.0.0.1
add address=10.10.10.1/24 interface=ether2 network=10.10.10.0
add address=10.10.20.1/24 interface=ether3 network=10.10.20.0
  • MikroTik-2
/interface bridge
add name=loopback

/ip address
add address=10.0.0.2 interface=loopback network=10.0.0.2
add address=10.10.10.2/24 interface=ether2 network=10.10.10.0
add address=192.168.1.1/24 interface=ether3 network=192.168.1.0
  • MikroTik-3
/interface bridge
add name=loopback

/ip address
add address=10.0.0.3 interface=loopback network=10.0.0.3
add address=10.10.20.2/24 interface=ether2 network=10.10.20.0
add address=192.168.2.1/24 interface=ether3 network=192.168.2.0
  • MikroTik-4
/interface bridge
add name=loopback

/ip address
add address=10.0.0.4 interface=loopback network=10.0.0.4
add address=192.168.1.2/24 interface=ether2 network=192.168.1.0
add address=192.168.10.1/24 interface=ether3 network=192.168.10.0
  • MikroTik-5
/interface bridge
add name=loopback

/ip address
add address=10.0.0.5 interface=loopback network=10.0.0.5
add address=192.168.2.2/24 interface=ether2 network=192.168.2.0
add address=192.168.10.1/24 interface=ether3 network=192.168.10.0

Setting Routing OSPF

  • MikroTik-1
/routing ospf instance
set [ find default=yes ] router-id=10.0.0.1

/routing ospf interface
add authentication=md5 authentication-key=sys-ops.id interface=ether2
add authentication=md5 authentication-key=sys-ops.id interface=ether3

/routing ospf network
add area=backbone network=10.10.10.0/24
add area=backbone network=10.10.20.0/24
add area=backbone network=10.0.0.1/32
  • MikroTik-2
/routing ospf area
add area-id=0.0.0.1 name=area1

/routing ospf instance
set [ find default=yes ] router-id=10.0.0.2

/routing ospf interface
add authentication=md5 authentication-key=sys-ops.id interface=ether2
add authentication=md5 authentication-key=sys-ops.id interface=ether3

/routing ospf network
add area=backbone network=10.0.0.2/32
add area=backbone network=10.10.10.0/24
add area=area1 network=192.168.1.0/24
  • MikroTik-3
/routing ospf area
add area-id=0.0.0.2 name=area2

/routing ospf instance
set [ find default=yes ] router-id=10.0.0.3

/routing ospf interface
add authentication=md5 authentication-key=sys-ops.id interface=ether3
add authentication=md5 authentication-key=sys-ops.id interface=ether2

/routing ospf network
add area=backbone network=10.0.0.3/32
add area=backbone network=10.10.20.0/24
add area=area2 network=192.168.2.0/24
  • MikroTik-4
/routing ospf area
add area-id=0.0.0.1 name=area1

/routing ospf instance
set [ find default=yes ] router-id=10.0.0.4

/routing ospf interface
add authentication=md5 authentication-key=sys-ops.id interface=ether2

/routing ospf network
add area=area1 network=192.168.1.0/24
add area=area1 network=10.0.0.4/32
  • MikroTik-5
/routing ospf area
add area-id=0.0.0.2 name=area2

/routing ospf instance
set [ find default=yes ] router-id=10.0.0.5

/routing ospf interface
add authentication=md5 authentication-key=sys-ops.id interface=ether2

/routing ospf network
add area=area2 network=192.168.2.0/24
add area=area2 network=10.0.0.5/32

Setting MPLS

  • MikroTik-1
/mpls ldp
set enabled=yes lsr-id=10.0.0.1 transport-address=10.0.0.1

/mpls ldp interface
add interface=ether2
add interface=ether3

/mpls ldp neighbor
add transport=10.0.0.2
add transport=10.0.0.3
  • MikroTik-2
/mpls ldp
set enabled=yes lsr-id=10.0.0.2 transport-address=10.0.0.2

/mpls ldp interface
add interface=ether2
add interface=ether3

/mpls ldp neighbor
add transport=10.0.0.1
add transport=10.0.0.4
  • MikroTik-3
/mpls ldp
set enabled=yes lsr-id=10.0.0.3 transport-address=10.0.0.3

/mpls ldp interface
add interface=ether2
add interface=ether3

/mpls ldp neighbor
add transport=10.0.0.1
add transport=10.0.0.5
  • MikroTik-4
/mpls ldp
set enabled=yes lsr-id=10.0.0.4 transport-address=10.0.0.4

/mpls ldp interface
add interface=ether2

/mpls ldp neighbor
add transport=10.0.0.2
  • MikroTik-5
/mpls ldp
set enabled=yes lsr-id=10.0.0.5 transport-address=10.0.0.5

/mpls ldp interface
add interface=ether2

/mpls ldp neighbor
add transport=10.0.0.3

Verifikasi

  • MikroTik-4 > Ping ke MikroTik-5 & Cek Routing Table
  • MikroTik-5 > Ping ke MikroTik-4 & Cek Routing Table

Setting VPLS

  • MikroTik-4
/interface vpls
add disabled=no name=vpls1 remote-peer=10.0.0.5 vpls-id=10:0

/interface bridge
add name=VPLS

/interface bridge port
add bridge=VPLS interface=vpls1
add bridge=VPLS interface=ether3
  • MikroTik-5
/interface vpls
add disabled=no name=vpls1 remote-peer=10.0.0.4 vpls-id=10:0

/interface bridge
add name=VPLS

/interface bridge port
add bridge=VPLS interface=vpls1
add bridge=VPLS interface=ether3

Pengujian

  • MikroTik-4 > Cek Routing Table, Cek MPLS LDP Neighbor, Cek MPLS Forwarding Table
  • MikroTik-5 > Cek Routing Table, Cek MPLS LDP Neighbor, Cek MPLS Forwarding Table

  • PC1 > Ping ke PC2
PC1> show ip
NAME        : PC1[1]
IP/MASK     : 192.168.10.10/24
GATEWAY     : 192.168.10.1
DNS         :
MAC         : 00:50:79:66:68:00
LPORT       : 10012
RHOST:PORT  : 127.0.0.1:10013
MTU:        : 1500

PC1> ping 192.168.10.20
84 bytes from 192.168.10.20 icmp_seq=1 ttl=64 time=5.549 ms
84 bytes from 192.168.10.20 icmp_seq=2 ttl=64 time=8.610 ms
84 bytes from 192.168.10.20 icmp_seq=3 ttl=64 time=8.976 ms
84 bytes from 192.168.10.20 icmp_seq=4 ttl=64 time=8.455 ms
84 bytes from 192.168.10.20 icmp_seq=5 ttl=64 time=9.182 ms

PC1> trace 192.168.10.20
trace to 192.168.10.20, 8 hops max, press Ctrl+C to stop
 1   192.168.10.20   0.957 ms  0.960 ms  0.767 ms
  • PC2 > Ping ke PC1
PC2> show ip
NAME        : PC2[1]
IP/MASK     : 192.168.10.20/24
GATEWAY     : 192.168.10.1
DNS         :
MAC         : 00:50:79:66:68:03
LPORT       : 10014
RHOST:PORT  : 127.0.0.1:10015
MTU:        : 1500

PC2> ping 192.168.10.10
84 bytes from 192.168.10.10 icmp_seq=1 ttl=64 time=4.833 ms
84 bytes from 192.168.10.10 icmp_seq=2 ttl=64 time=3.282 ms
84 bytes from 192.168.10.10 icmp_seq=3 ttl=64 time=3.989 ms
84 bytes from 192.168.10.10 icmp_seq=4 ttl=64 time=2.685 ms
84 bytes from 192.168.10.10 icmp_seq=5 ttl=64 time=8.872 ms

PC2> trace 192.168.10.10
trace to 192.168.10.10, 8 hops max, press Ctrl+C to stop
 1   192.168.10.10    0.651 ms  0.572 ms  0.818 ms

herdiana3389

A system administrator with skills in system administration, virtualization, linux, windows, networking, cloud computing, container, etc.