Setting Remote Login Telnet and SSH Cisco – GNS3 Lab11

Setting Remote Login Telnet dan SSH Cisco Router dan Switch – GNS3 Lab11

  • R1 : 192.168.10.1
  • SW1 : 192.168.10.2 (vlan1)
  • PC1 : 192.168.10.3

Setting Telnet dan SSH

  • R1 – Telnet
R1# configure terminal
R1(config)# interface fastEthernet 0/1
R1(config-if)# ip address 192.168.10.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

R1# configure terminal
R1(config)# username sysops password cisco
R1(config)# enable password cisco-ops
R1(config)# line vty 0 4
R1(config-line)# login local
R1(config-line)# transport input telnet ssh
R1(config-line)# exit
  • R1 – SSH
R1(config)# ip domain name sys-ops.id
R1(config)# hostname sys-ops.id

sys-ops.id(config)# crypto key generate rsa
The name for the keys will be: sys-ops.id.sys-ops.id
Choose the size of the key modulus in the range of 360 to 2048 for your
  General Purpose Keys. Choosing a key modulus greater than 512 may take
  a few minutes.

How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

*Mar  1 00:30:34.903: %SSH-5-ENABLED: SSH 1.99 has been enabled
sys-ops.id(config)#

  • SW1 – Telnet
SW1# configure terminal
SW1(config)# interface fastEthernet 0/0
SW1(config-if)# no shutdown
SW1(config-if)# exit

SW1(config)#interface fastEthernet 0/1
SW1(config-if)#no shutdown
SW1(config-if)#exit
SW1(config)#

SW1# configure terminal
SW1(config)# username sysops password cisco
SW1(config)# enable password cisco-ops
SW1(config)# line vty 0 4
SW1(config-line)# login local
SW1(config-line)# transport input telnet ssh
SW1(config-line)# exit

SW1(config)# interface vlan 1
SW1(config-if)# ip address 192.168.10.2 255.255.255.0
SW1(config-if)# no shutdown
SW1(config-if)# exit
  • SW1 – SSH
SW1(config)# ip domain name sys-ops.id
SW1(config)# hostname sys-ops.id

sys-ops.id(config)# crypto key generate rsa
The name for the keys will be: sys-ops.id.sys-ops.id
Choose the size of the key modulus in the range of 360 to 2048 for your
  General Purpose Keys. Choosing a key modulus greater than 512 may take
  a few minutes.

How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

*Mar  1 00:38:24.899: %SSH-5-ENABLED: SSH 1.99 has been enabled
sys-ops.id(config)#

Pengujian

  • Test telnet ke dalam router dan switch lewat PC1 > berhasil
  • Test ssh ke dalam router dan switch lewat PC1 > berhasil

herdiana3389

A system administrator with skills in system administration, virtualization, linux, windows, networking, cloud computing, container, etc.