Setting Routing EIGRP Cisco – GNS3 Lab13

Setting Routing EIGRP (Enhanced Interior Gateway Routing Protocol) Cisco – GNS3 Lab13

  • R1 Serial 1/2 : 10.10.10.1
  • R1 Serial 1/3 : 30.30.30.1
  • R1 FastEthernet 0/0 : 192.168.10.1
  • R2 Serial 1/1 : 20.20.20.2
  • R2 Serial 1/2 : 10.10.10.2
  • R3 Serial 1/1 : 20.20.20.1
  • R3 Serial 1/3 : 30.30.30.2
  • R3 FastEthernet 0/0 : 192.168.20.1

R1

  • Setting IP address R1
R1# configure terminal
R1(config)# interface serial 1/2
R1(config-if)# ip address 10.10.10.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

R1(config)# interface serial 1/3
R1(config-if)# ip address 30.30.30.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

R1(config)# interface fastEthernet 0/0
R1(config-if)# ip address 192.168.10.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit
  • Setting EIGRP R1
R1(config)# router eigrp 10
R1(config-router)# network 10.10.10.0 0.0.0.255
R1(config-router)# network 30.30.30.0 0.0.0.255
R1(config-router)# network 192.168.10.0 0.0.0.255
R1(config-router)# exit
R1(config)#

R2

  • Setting IP address R2
R2# configure terminal
R2(config)# interface serial 1/2
R2(config-if)# ip address 10.10.10.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# exit

R2(config)# interface serial 1/1
R2(config-if)# ip address 20.20.20.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# exit
  • Setting EIGRP R2
R2(config)# router eigrp 10
R2(config-router)# network 10.10.10.0 0.0.0.255
R2(config-router)# network 20.20.20.0 0.0.0.255
R2(config-router)# exit
R2(config)#

R3

  • Setting IP address R3
R3# configure terminal
R3(config)# interface serial 1/1
R3(config-if)# ip address 20.20.20.1 255.255.255.0
R3(config-if)# no shutdown
R3(config-if)# exit

R3(config)# interface serial 1/3
R3(config-if)# ip address 30.30.30.2 255.255.255.0
R3(config-if)# no shutdown
R3(config-if)# exit

R3(config)# interface fastEthernet 0/0
R3(config-if)# ip address 192.168.20.1 255.255.255.0
R3(config-if)# no shutdown
R3(config-if)# exit
  • Setting EIGRP R3
R3(config)# router eigrp 10
R3(config-router)# network 20.20.20.0 0.0.0.255
R3(config-router)# network 30.30.30.0 0.0.0.255
R3(config-router)# network 192.168.20.0 0.0.0.255
R3(config-router)# exit
R3(config)#

Cek Konfigurasi EIGRP

  • R1
R1# show ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   30.30.30.2              Se1/3             14 00:07:56   45   270  0  25
0   10.10.10.2              Se1/2             12 00:08:46   39   234  0  23


R1# show ip eigrp topology
IP-EIGRP Topology Table for AS(10)/ID(1.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status
P 10.0.0.0/8, 1 successors, FD is 2169856
        via Summary (2169856/0), Null0
P 10.10.10.0/24, 1 successors, FD is 2169856
        via Connected, Serial1/2
P 20.0.0.0/8, 2 successors, FD is 2681856
        via 10.10.10.2 (2681856/2169856), Serial1/2
        via 30.30.30.2 (2681856/2169856), Serial1/3
P 30.0.0.0/8, 1 successors, FD is 2169856
        via Summary (2169856/0), Null0
P 30.30.30.0/24, 1 successors, FD is 2169856
        via Connected, Serial1/3
P 192.168.10.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/0
P 192.168.20.0/24, 1 successors, FD is 2172416
        via 30.30.30.2 (2172416/28160), Serial1/3


R1# show ip eigrp interfaces
IP-EIGRP interfaces for process 10
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se1/2              1        0/0        39       0/15         171           0
Se1/3              1        0/0        45       0/15         199           0
Fa0/0              0        0/0         0       0/1            0           0


R1# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set
D    20.0.0.0/8 [90/2681856] via 30.30.30.2, 00:08:11, Serial1/3
                [90/2681856] via 10.10.10.2, 00:08:11, Serial1/2
C    192.168.10.0/24 is directly connected, FastEthernet0/0
D    192.168.20.0/24 [90/2172416] via 30.30.30.2, 00:08:06, Serial1/3
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.10.10.0/24 is directly connected, Serial1/2
D       10.0.0.0/8 is a summary, 00:00:34, Null0
     30.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       30.30.30.0/24 is directly connected, Serial1/3
D       30.0.0.0/8 is a summary, 00:00:34, Null0
  • R2
R2# show ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   20.20.20.1              Se1/1             11 00:09:54   28   200  0  26
0   10.10.10.1              Se1/2             14 00:10:37   37   222  0  24


R2# show ip eigrp topology
IP-EIGRP Topology Table for AS(10)/ID(2.2.2.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status
P 10.0.0.0/8, 1 successors, FD is 2169856
        via Summary (2169856/0), Null0
P 10.10.10.0/24, 1 successors, FD is 2169856
        via Connected, Serial1/2
P 20.0.0.0/8, 1 successors, FD is 2169856
        via Summary (2169856/0), Null0
P 20.20.20.0/24, 1 successors, FD is 2169856
        via Connected, Serial1/1
P 30.0.0.0/8, 2 successors, FD is 2681856
        via 10.10.10.1 (2681856/2169856), Serial1/2
        via 20.20.20.1 (2681856/2169856), Serial1/1
P 192.168.10.0/24, 1 successors, FD is 2172416
        via 10.10.10.1 (2172416/28160), Serial1/2
P 192.168.20.0/24, 1 successors, FD is 2172416
        via 20.20.20.1 (2172416/28160), Serial1/1


R2# show ip eigrp interfaces
IP-EIGRP interfaces for process 10
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se1/2              1        0/0        37       0/15         163           0
Se1/1              1        0/0        28       0/15         127           0


R2# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set
     20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       20.20.20.0/24 is directly connected, Serial1/1
D       20.0.0.0/8 is a summary, 00:11:33, Null0
D    192.168.10.0/24 [90/2172416] via 10.10.10.1, 00:10:49, Serial1/2
D    192.168.20.0/24 [90/2172416] via 20.20.20.1, 00:10:44, Serial1/1
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.10.10.0/24 is directly connected, Serial1/2
D       10.0.0.0/8 is a summary, 00:03:11, Null0
D    30.0.0.0/8 [90/2681856] via 20.20.20.1, 00:03:11, Serial1/1
                [90/2681856] via 10.10.10.1, 00:03:11, Serial1/2
  • R3
R3# show ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   30.30.30.1              Se1/3             12 00:12:01  172  1032  0  25
0   20.20.20.2              Se1/1             14 00:12:08   33   200  0  24


R3# show ip eigrp topology
IP-EIGRP Topology Table for AS(10)/ID(3.3.3.3)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status
P 10.0.0.0/8, 2 successors, FD is 2681856
        via 20.20.20.2 (2681856/2169856), Serial1/1
        via 30.30.30.1 (2681856/2169856), Serial1/3
P 20.0.0.0/8, 1 successors, FD is 2169856
        via Summary (2169856/0), Null0
P 20.20.20.0/24, 1 successors, FD is 2169856
        via Connected, Serial1/1
P 30.30.30.0/24, 1 successors, FD is 2169856
        via Connected, Serial1/3
P 30.0.0.0/8, 1 successors, FD is 2169856
        via Summary (2169856/0), Null0
P 192.168.10.0/24, 1 successors, FD is 2172416
        via 30.30.30.1 (2172416/28160), Serial1/3
P 192.168.20.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/0


R3# show ip eigrp interfaces
IP-EIGRP interfaces for process 10
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se1/1              1        0/0        33       0/15         139           0
Se1/3              1        0/0       172       0/15         847           0
Fa0/0              0        0/0         0       0/1            0           0


R3# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set
     20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       20.20.20.0/24 is directly connected, Serial1/1
D       20.0.0.0/8 is a summary, 00:12:31, Null0
D    192.168.10.0/24 [90/2172416] via 30.30.30.1, 00:12:29, Serial1/3
C    192.168.20.0/24 is directly connected, FastEthernet0/0
D    10.0.0.0/8 [90/2681856] via 30.30.30.1, 00:04:49, Serial1/3
                [90/2681856] via 20.20.20.2, 00:04:49, Serial1/1
     30.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       30.30.30.0/24 is directly connected, Serial1/3
D       30.0.0.0/8 is a summary, 00:04:51, Null0

Pengujian EIGRP

  • Test ping dari PC1 ke PC2
  • Test traceroute dari PC1 ke PC2 > paket dikirimkan lewat R1 ke R3
PC1> ip 192.168.10.2/24 192.168.10.1
Checking for duplicate address...
PC1 : 192.168.10.2 255.255.255.0 gateway 192.168.10.1

PC1> show ip

NAME        : PC1[1]
IP/MASK     : 192.168.10.2/24
GATEWAY     : 192.168.10.1
DNS         :
MAC         : 00:50:79:66:68:00
LPORT       : 10026
RHOST:PORT  : 127.0.0.1:10027
MTU:        : 1500

PC1> ping 192.168.20.2
192.168.20.2 icmp_seq=1 timeout
84 bytes from 192.168.20.2 icmp_seq=2 ttl=62 time=61.219 ms
84 bytes from 192.168.20.2 icmp_seq=3 ttl=62 time=60.290 ms
84 bytes from 192.168.20.2 icmp_seq=4 ttl=62 time=60.247 ms
84 bytes from 192.168.20.2 icmp_seq=5 ttl=62 time=60.161 ms

PC1> trace 192.168.20.2
trace to 192.168.20.2, 8 hops max, press Ctrl+C to stop
 1   192.168.10.1   15.289 ms  14.975 ms  15.203 ms
 2   30.30.30.2   44.875 ms  44.950 ms  45.065 ms
 3   *192.168.20.2   59.914 ms (ICMP type:3, code:3, Destination port unreachable)
  • Test ping dari PC2 ke PC1
  • Test traceroute dari PC2 ke PC1 > paket dikirimkan lewat R3 ke R1
PC2> ip 192.168.20.2/24 192.168.20.1
Checking for duplicate address...
PC1 : 192.168.20.2 255.255.255.0 gateway 192.168.20.1

PC2> show ip

NAME        : PC2[1]
IP/MASK     : 192.168.20.2/24
GATEWAY     : 192.168.20.1
DNS         :
MAC         : 00:50:79:66:68:01
LPORT       : 10028
RHOST:PORT  : 127.0.0.1:10029
MTU:        : 1500

PC2> ping 192.168.10.2
84 bytes from 192.168.10.2 icmp_seq=1 ttl=62 time=60.067 ms
84 bytes from 192.168.10.2 icmp_seq=2 ttl=62 time=60.245 ms
84 bytes from 192.168.10.2 icmp_seq=3 ttl=62 time=60.255 ms
84 bytes from 192.168.10.2 icmp_seq=4 ttl=62 time=60.133 ms
84 bytes from 192.168.10.2 icmp_seq=5 ttl=62 time=60.220 ms

PC2> trace 192.168.10.2
trace to 192.168.10.2, 8 hops max, press Ctrl+C to stop
 1   192.168.20.1   15.226 ms  15.052 ms  14.981 ms
 2   30.30.30.1   44.903 ms  45.107 ms  45.003 ms
 3   *192.168.10.2   60.109 ms (ICMP type:3, code:3, Destination port unreachable)

  • Pengujian tambahan, disconnect/suspend jalur yang mengarah dari dan ke R1 dan R3
  • Traceroute dari PC1 ke PC2 > paket dikirimkan lewat R1 ke R2 ke R3
PC1> trace 192.168.20.2
trace to 192.168.20.2, 8 hops max, press Ctrl+C to stop
 1   192.168.10.1   15.526 ms  15.240 ms  15.071 ms
 2   10.10.10.2   45.032 ms  44.724 ms  44.983 ms
 3   20.20.20.1   74.913 ms  74.990 ms  74.887 ms
 4   *192.168.20.2   90.628 ms (ICMP type:3, code:3, Destination port unreachable)
  • Traceroute dari PC2 ke PC1 > paket dikirimkan lewat R3 ke R2 ke R1
PC2> trace 192.168.10.2
trace to 192.168.10.2, 8 hops max, press Ctrl+C to stop
 1   192.168.20.1   15.090 ms  15.355 ms  15.269 ms
 2   20.20.20.2   45.021 ms  44.925 ms  45.156 ms
 3   10.10.10.1   75.995 ms  75.079 ms  74.911 ms
 4   *192.168.10.2   90.070 ms (ICMP type:3, code:3, Destination port unreachable)


  • Remove Konfigurasi EIGRP
R1# clear ip eigrp neighbors
R1# configure terminal
R1(config)# router eigrp 10
R1(config-router)# no network 10.10.10.0 0.0.0.255
R1(config-router)# no network 30.30.30.0 0.0.0.255
R1(config-router)# no network 192.168.10.0 0.0.0.255
R1(config-router)# exit
R1(config)# no router eigrp 10
R1(config)# exit

herdiana3389

A system administrator with skills in system administration, virtualization, linux, windows, networking, cloud computing, container, etc.