Setting Routing OSPF MikroTik – GNS3 Lab45

Setting Routing OSPF MikroTik – GNS3 Lab45

  • MikroTik-1 ether1: 10.10.10.1/24
  • MikroTik-1 ether2: 192.168.1.1/24
  • MikroTik-1 ether3: 30.30.30.1/24
  • MikroTik-2 ether1: 10.10.10.2/24
  • MikroTik-2 ether2: 20.20.20.2/24
  • MikroTik-2 ether3: 192.168.3.1/24
  • MikroTik-3 ether1: 20.20.20.1/24
  • MikroTik-3 ether2: 192.168.3.1/24
  • MikroTik-3 ether3: 30.30.30.2/24
  • PC1: 192.168.1.2/24
  • PC2: 192.168.2.2/24
  • PC3: 192.168.3.2/24

Setting IP Address

  • MikroTik-1
/ip address
add address=10.10.10.1/24 interface=ether1 network=10.10.10.0
add address=192.168.1.1/24 interface=ether2 network=192.168.1.0
add address=30.30.30.1/24 interface=ether3 network=30.30.30.0
  • MikroTik-2
/ip address
add address=10.10.10.2/24 interface=ether1 network=10.10.10.0
add address=20.20.20.2/24 interface=ether2 network=20.20.20.0
add address=192.168.2.1/24 interface=ether3 network=192.168.2.0
  • MikroTik-3
/ip address
add address=20.20.20.1/24 interface=ether1 network=20.20.20.0
add address=192.168.3.1/24 interface=ether2 network=192.168.3.0
add address=30.30.30.2/24 interface=ether3 network=30.30.30.0

Setting Routing OSPF

  • MikroTik-1
/routing ospf instance
set [ find default=yes ] router-id=0.0.0.1

/routing ospf interface
add authentication=md5 authentication-key=sys-ops.id interface=ether1 network-type=broadcast
add authentication=md5 authentication-key=sys-ops.id interface=ether3 network-type=broadcast
add authentication=md5 authentication-key=sys-ops.id interface=ether2 network-type=broadcast

/routing ospf network
add area=backbone network=10.10.10.0/24
add area=backbone network=30.30.30.0/24
add area=backbone network=192.168.1.0/24
  • MikroTik-2
/routing ospf instance
set [ find default=yes ] router-id=0.0.0.2

/routing ospf interface
add authentication=md5 authentication-key=sys-ops.id interface=ether1 network-type=broadcast
add authentication=md5 authentication-key=sys-ops.id interface=ether2 network-type=broadcast
add authentication=md5 authentication-key=sys-ops.id interface=ether3 network-type=broadcast

/routing ospf network
add area=backbone network=10.10.10.0/24
add area=backbone network=20.20.20.0/24
add area=backbone network=192.168.2.0/24
  • MikroTik-3
/routing ospf instance
set [ find default=yes ] router-id=0.0.0.3

/routing ospf interface
add authentication=md5 authentication-key=sys-ops.id interface=ether1 network-type=broadcast
add authentication=md5 authentication-key=sys-ops.id interface=ether3 network-type=broadcast
add authentication=md5 authentication-key=sys-ops.id interface=ether2 network-type=broadcast

/routing ospf network
add area=backbone network=20.20.20.0/24
add area=backbone network=30.30.30.0/24
add area=backbone network=192.168.3.0/24

Pengujian

  • Cek table routing MikroTik-1
  • Cek table routing MikroTik-2
  • Cek table routing MikroTik-3

  • PC1 > Ping ke PC2 dan PC3
PC1> ip 192.168.1.2/24 192.168.1.1
Checking for duplicate address...
PC1 : 192.168.1.2 255.255.255.0 gateway 192.168.1.1

PC1> ping 192.168.2.2
84 bytes from 192.168.2.2 icmp_seq=1 ttl=62 time=3.063 ms
84 bytes from 192.168.2.2 icmp_seq=2 ttl=62 time=2.650 ms
84 bytes from 192.168.2.2 icmp_seq=3 ttl=62 time=2.038 ms
84 bytes from 192.168.2.2 icmp_seq=4 ttl=62 time=2.499 ms
84 bytes from 192.168.2.2 icmp_seq=5 ttl=62 time=2.041 ms

PC1> ping 192.168.3.2
84 bytes from 192.168.3.2 icmp_seq=1 ttl=62 time=1.935 ms
84 bytes from 192.168.3.2 icmp_seq=2 ttl=62 time=2.265 ms
84 bytes from 192.168.3.2 icmp_seq=3 ttl=62 time=2.073 ms
84 bytes from 192.168.3.2 icmp_seq=4 ttl=62 time=2.407 ms
84 bytes from 192.168.3.2 icmp_seq=5 ttl=62 time=1.852 ms
  • PC2 > Ping ke PC1 dan PC3
PC2> ip 192.168.2.2/24 192.168.2.1
Checking for duplicate address...
PC1 : 192.168.2.2 255.255.255.0 gateway 192.168.2.1

PC2> ping 192.168.1.2
84 bytes from 192.168.1.2 icmp_seq=1 ttl=62 time=2.322 ms
84 bytes from 192.168.1.2 icmp_seq=2 ttl=62 time=2.495 ms
84 bytes from 192.168.1.2 icmp_seq=3 ttl=62 time=2.353 ms
84 bytes from 192.168.1.2 icmp_seq=4 ttl=62 time=1.875 ms
84 bytes from 192.168.1.2 icmp_seq=5 ttl=62 time=2.183 ms

PC2> ping 192.168.3.2
84 bytes from 192.168.3.2 icmp_seq=1 ttl=62 time=3.136 ms
84 bytes from 192.168.3.2 icmp_seq=2 ttl=62 time=2.295 ms
84 bytes from 192.168.3.2 icmp_seq=3 ttl=62 time=1.988 ms
84 bytes from 192.168.3.2 icmp_seq=4 ttl=62 time=1.826 ms
84 bytes from 192.168.3.2 icmp_seq=5 ttl=62 time=2.040 ms
  • PC3 > Ping ke PC1 dan PC2
PC3> ip 192.168.3.2/24 192.168.3.1
Checking for duplicate address...
PC1 : 192.168.3.2 255.255.255.0 gateway 192.168.3.1

PC3> ping 192.168.1.2
84 bytes from 192.168.1.2 icmp_seq=1 ttl=62 time=1.838 ms
84 bytes from 192.168.1.2 icmp_seq=2 ttl=62 time=1.978 ms
84 bytes from 192.168.1.2 icmp_seq=3 ttl=62 time=1.977 ms
84 bytes from 192.168.1.2 icmp_seq=4 ttl=62 time=1.897 ms
84 bytes from 192.168.1.2 icmp_seq=5 ttl=62 time=1.831 ms

PC3> ping 192.168.2.2
84 bytes from 192.168.2.2 icmp_seq=1 ttl=62 time=2.190 ms
84 bytes from 192.168.2.2 icmp_seq=2 ttl=62 time=2.000 ms
84 bytes from 192.168.2.2 icmp_seq=3 ttl=62 time=2.188 ms
84 bytes from 192.168.2.2 icmp_seq=4 ttl=62 time=2.125 ms
84 bytes from 192.168.2.2 icmp_seq=5 ttl=62 time=2.485 ms

herdiana3389

A system administrator with skills in system administration, virtualization, linux, windows, networking, cloud computing, container, etc.