Setting Routing OSPF Virtual Link MikroTik – GNS3 Lab48

Setting Routing OSPF Virtual Link MikroTik – GNS3 Lab48

  • MikroTik-1 ether1: 10.10.10.1/24 > Area backbone
  • MikroTik-1 ether2: 192.168.1.1/24 > Area backbone
  • MikroTik-1 ether3: 30.30.30.1/24 > Area backbone
  • MikroTik-2 ether1: 10.10.10.2/24 > Area backbone
  • MikroTik-2 ether2: 20.20.20.2/24 > Area backbone
  • MikroTik-2 ether3: 40.40.40.1/24 > Area 1 (set Virtual Link)
  • MikroTik-3 ether1: 20.20.20.1/24 > Area backbone
  • MikroTik-3 ether2: 192.168.3.1/24 > Area backbone
  • MikroTik-3 ether3: 30.30.30.2/24 > Area backbone
  • MikroTik-4 ether1: 40.40.40.2/24 > Area 1 (set Virtual Link)
  • MikroTik-4 ether2: 50.50.50.2/24 > Area 2
  • MikroTik-4-ether3: 60.60.60.2/24 > Area 3
  • MikroTik-5 ether1: 50.50.50.1/24 > Area 2
  • MikroTik-5 ether1: 192.168.2.1/24 > Area 2
  • MikroTik-5 ether1: 60.60.60.1/24 > Area 3
  • MikroTik-5 ether1: 192.168.4.1/24 > Area 3
  • Router ID MikroTik-1: 0.0.0.1
  • Router ID MikroTik-2: 0.0.0.2
  • Router ID MikroTik-3: 0.0.0.3
  • Router ID MikroTik-4: 0.0.0.4
  • Router ID MikroTik-5: 0.0.0.5
  • Router ID MikroTik-6: 0.0.0.6
  • PC1: 192.168.1.2/24
  • PC2: 192.168.2.2/24
  • PC3: 192.168.3.2/24
  • PC4: 192.168.4.2/24

Setting IP Address

  • MikroTik-1
/ip address
add address=10.10.10.1/24 interface=ether1 network=10.10.10.0
add address=192.168.1.1/24 interface=ether2 network=192.168.1.0
add address=30.30.30.1/24 interface=ether3 network=30.30.30.0
  • MikroTik-2
/ip address
add address=10.10.10.2/24 interface=ether1 network=10.10.10.0
add address=20.20.20.2/24 interface=ether2 network=20.20.20.0
add address=40.40.40.1/24 interface=ether3 network=40.40.40.0
  • MikroTik-3
/ip address
add address=20.20.20.1/24 interface=ether1 network=20.20.20.0
add address=192.168.3.1/24 interface=ether2 network=192.168.3.0
add address=30.30.30.2/24 interface=ether3 network=30.30.30.0
  • MikroTik-4
/ip address
add address=40.40.40.2/24 interface=ether1 network=40.40.40.0
add address=50.50.50.2/24 interface=ether2 network=50.50.50.0
add address=60.60.60.2/24 interface=ether3 network=60.60.60.0
  • MikroTik-5
/ip address
add address=50.50.50.1/24 interface=ether1 network=50.50.50.0
add address=192.168.2.1/24 interface=ether2 network=192.168.2.0
  • MikroTik-6
/ip address
add address=60.60.60.2/24 interface=ether1 network=60.60.60.0
add address=192.168.4.1/24 interface=ether2 network=192.168.4.0

Setting Routing OSPF Multi Area

  • MikroTik-1
/routing ospf instance
set [ find default=yes ] router-id=0.0.0.1

/routing ospf interface
add authentication=md5 authentication-key=sys-ops.id interface=ether1 network-type=broadcast
add authentication=md5 authentication-key=sys-ops.id interface=ether3 network-type=broadcast
add authentication=md5 authentication-key=sys-ops.id interface=ether2 network-type=broadcast

/routing ospf network
add area=backbone network=10.10.10.0/24
add area=backbone network=30.30.30.0/24
add area=backbone network=192.168.1.0/24
  • MikroTik-2
/routing ospf instance
set [ find default=yes ] router-id=0.0.0.2

/routing ospf area
add area-id=0.0.0.1 name=area1

/routing ospf interface
add authentication=md5 authentication-key=sys-ops.id interface=ether1 network-type=broadcast
add authentication=md5 authentication-key=sys-ops.id interface=ether2 network-type=broadcast
add authentication=md5 authentication-key=sys-ops.id interface=ether3 network-type=broadcast

/routing ospf network
add area=backbone network=10.10.10.0/24
add area=backbone network=20.20.20.0/24
add area=area1 network=40.40.40.0/24
  • MikroTik-3
/routing ospf instance
set [ find default=yes ] router-id=0.0.0.3

/routing ospf interface
add authentication=md5 authentication-key=sys-ops.id interface=ether1 network-type=broadcast
add authentication=md5 authentication-key=sys-ops.id interface=ether3 network-type=broadcast
add authentication=md5 authentication-key=sys-ops.id interface=ether2 network-type=broadcast

/routing ospf network
add area=backbone network=20.20.20.0/24
add area=backbone network=30.30.30.0/24
add area=backbone network=192.168.3.0/24
  • MikroTik-4
/routing ospf instance
set [ find default=yes ] router-id=0.0.0.4

/routing ospf area
add area-id=0.0.0.1 name=area1
add area-id=0.0.0.2 name=area2
add area-id=0.0.0.3 name=area3

/routing ospf interface
add authentication=md5 authentication-key=sys-ops.id interface=ether1
add authentication=md5 authentication-key=sys-ops.id interface=ether2
add authentication=md5 authentication-key=sys-ops.id interface=ether3

/routing ospf network
add area=area1 network=40.40.40.0/24
add area=area2 network=50.50.50.0/24
add area=area3 network=60.60.60.0/24
  • MikroTik-5
/routing ospf instance
set [ find default=yes ] router-id=0.0.0.5

/routing ospf area
add area-id=0.0.0.2 name=area2

/routing ospf interface
add authentication=md5 authentication-key=sys-ops.id interface=ether1
add authentication=md5 authentication-key=sys-ops.id interface=ether2

/routing ospf network
add area=area2 network=50.50.50.0/24
add area=area2 network=192.168.2.0/24
  • MikroTik-6
/routing ospf instance
set [ find default=yes ] router-id=0.0.0.6

/routing ospf area
add area-id=0.0.0.2 name=area2

/routing ospf interface
add authentication=md5 authentication-key=sys-ops.id interface=ether1
add authentication=md5 authentication-key=sys-ops.id interface=ether2

/routing ospf network
add area=area3 network=60.60.60.0/24
add area=area3 network=192.168.4.0/24

Setting OSPF Virtual Link

  • Virtual Link digunakan untuk menghubungkan router yang berada di area backbone dengan dengan router yang berada di luar area backbone. Pada kasus artikel ini (bisa di lihat topologi gambar paling atas) Router MikroTik-4, MikroTik-5, dan MikroTik-6 tidak terhubung langsung dengan area backbone, sehingga PC1 dan PC3 tidak bisa berkomunikasi dengan PC2 dan PC4.
  • Pada kasus artikel ini MikroTik-2 terhubung dengan area backbone dan juga terhubung langusng dengan MikroTik-4 di area 1. Jadi virtual link akan di buat di MikroTik-2 dan MikroTik-4 agar router yang berada di luar area backbone bisa saling terhubung dan bertukar tabel routing.
  • Untk membuat virtual link, diharuskan mengetahui masing-masing Router ID yang ada pada MikroTik-2 dan MikroTik-4.
  • MikroTik-2 dan MikroTik-4 berada di dalam area 1, jadi virtual link-nya menggunakan area 1.
  • MikroTik-2
/routing ospf virtual-link
add authentication=md5 authentication-key=sys-ops.id neighbor-id=0.0.0.4 transit-area=area1
  • MikroTik-4
/routing ospf virtual-link
add authentication=md5 authentication-key=sys-ops.id neighbor-id=0.0.0.2 transit-area=area1

Pengujian

  • Cek table routing MikroTik-1
  • Cek table routing MikroTik-2
  • Cek table routing MikroTik-3
  • Cek table routing MikroTik-4
  • Cek table routing MikroTik-5
  • Cek table routing MikroTik-6

  • PC1 > Ping ke PC2 & PC4
PC1> ip 192.168.1.2/24 192.168.1.1
Checking for duplicate address...
PC1 : 192.168.1.2 255.255.255.0 gateway 192.168.1.1

PC1> ping 192.168.2.2
84 bytes from 192.168.2.2 icmp_seq=1 ttl=60 time=6.248 ms
84 bytes from 192.168.2.2 icmp_seq=2 ttl=60 time=4.424 ms
84 bytes from 192.168.2.2 icmp_seq=3 ttl=60 time=3.661 ms
84 bytes from 192.168.2.2 icmp_seq=4 ttl=60 time=3.976 ms
84 bytes from 192.168.2.2 icmp_seq=5 ttl=60 time=4.739 ms

PC1> ping 192.168.4.2
84 bytes from 192.168.4.2 icmp_seq=1 ttl=60 time=5.125 ms
84 bytes from 192.168.4.2 icmp_seq=2 ttl=60 time=3.465 ms
84 bytes from 192.168.4.2 icmp_seq=3 ttl=60 time=3.872 ms
84 bytes from 192.168.4.2 icmp_seq=4 ttl=60 time=4.560 ms
84 bytes from 192.168.4.2 icmp_seq=5 ttl=60 time=5.417 ms
  • PC3 > Ping ke PC2 & PC4
PC3> ip 192.168.3.2/24 192.168.3.1
Checking for duplicate address...
PC1 : 192.168.3.2 255.255.255.0 gateway 192.168.3.1

PC3> ping 192.168.2.2
84 bytes from 192.168.2.2 icmp_seq=1 ttl=60 time=5.049 ms
84 bytes from 192.168.2.2 icmp_seq=2 ttl=60 time=4.155 ms
84 bytes from 192.168.2.2 icmp_seq=3 ttl=60 time=4.119 ms
84 bytes from 192.168.2.2 icmp_seq=4 ttl=60 time=3.847 ms
84 bytes from 192.168.2.2 icmp_seq=5 ttl=60 time=4.093 ms

PC3> ping 192.168.4.2
84 bytes from 192.168.4.2 icmp_seq=1 ttl=60 time=3.894 ms
84 bytes from 192.168.4.2 icmp_seq=2 ttl=60 time=4.471 ms
84 bytes from 192.168.4.2 icmp_seq=3 ttl=60 time=4.034 ms
84 bytes from 192.168.4.2 icmp_seq=4 ttl=60 time=3.862 ms
84 bytes from 192.168.4.2 icmp_seq=5 ttl=60 time=5.240 ms

  • PC2 > Ping ke PC1 & PC3
PC2> ip 192.168.2.2/24 192.168.2.1
Checking for duplicate address...
PC1 : 192.168.2.2 255.255.255.0 gateway 192.168.2.1

PC2> ping 192.168.1.2
84 bytes from 192.168.1.2 icmp_seq=1 ttl=60 time=3.937 ms
84 bytes from 192.168.1.2 icmp_seq=2 ttl=60 time=4.066 ms
84 bytes from 192.168.1.2 icmp_seq=3 ttl=60 time=4.275 ms
84 bytes from 192.168.1.2 icmp_seq=4 ttl=60 time=4.435 ms
84 bytes from 192.168.1.2 icmp_seq=5 ttl=60 time=3.973 ms

PC2> ping 192.168.3.2
84 bytes from 192.168.3.2 icmp_seq=1 ttl=60 time=3.904 ms
84 bytes from 192.168.3.2 icmp_seq=2 ttl=60 time=3.745 ms
84 bytes from 192.168.3.2 icmp_seq=3 ttl=60 time=3.654 ms
84 bytes from 192.168.3.2 icmp_seq=4 ttl=60 time=4.762 ms
84 bytes from 192.168.3.2 icmp_seq=5 ttl=60 time=4.943 ms
  • PC4 > Ping ke PC1 & PC3
PC4> ip 192.168.4.2/24 192.168.4.1
Checking for duplicate address...
PC1 : 192.168.4.2 255.255.255.0 gateway 192.168.4.1

PC4> ping 192.168.1.2
84 bytes from 192.168.1.2 icmp_seq=1 ttl=60 time=4.159 ms
84 bytes from 192.168.1.2 icmp_seq=2 ttl=60 time=4.480 ms
84 bytes from 192.168.1.2 icmp_seq=3 ttl=60 time=3.874 ms
84 bytes from 192.168.1.2 icmp_seq=4 ttl=60 time=4.583 ms
84 bytes from 192.168.1.2 icmp_seq=5 ttl=60 time=3.670 ms

PC4> ping 192.168.3.2
84 bytes from 192.168.3.2 icmp_seq=1 ttl=60 time=3.760 ms
84 bytes from 192.168.3.2 icmp_seq=2 ttl=60 time=3.951 ms
84 bytes from 192.168.3.2 icmp_seq=3 ttl=60 time=4.279 ms
84 bytes from 192.168.3.2 icmp_seq=4 ttl=60 time=3.688 ms
84 bytes from 192.168.3.2 icmp_seq=5 ttl=60 time=4.477 ms

herdiana3389

A system administrator with skills in system administration, virtualization, linux, windows, networking, cloud computing, container, etc.