Setting VLAN Trunking Cisco – GNS3 Lab7

Setting VLAN Trunking Cisco Switch – GNS3 Lab7

Artikel ini melanjutkan dari artikel sebelumnya: Setting VLAN Cisco – GNS3 Lab6

  • SW1: FastEthernet 0/10 mode trunk
  • SW2: FastEthernet 0/0 mode trunk
  • SW2: FastEthernet 0/1 – 0/4 mode access vlan 10
  • SW2: FastEthernet 0/5 – 0/8 mode access vlan 20

SW1

  • Setting mode trunk pada FastEthernet 0/10
SW1# configure terminal
SW1(config)# interface fastEthernet 0/10
SW1(config-if)# switchport trunk encapsulation dot1q
SW1(config-if)# switchport mode trunk
SW1(config-if)# no shutdown
SW1(config-if)# exit
  • Cek status vlan pada switch setelah di konfigurasi
SW1# show interfaces status
Port    Name               Status       Vlan       Duplex Speed Type
Fa0/0   *** Unused for Lay connected    trunk      a-full   a-100 10/100BaseTX
Fa0/1   *** Unused for Lay connected    10         a-full   a-100 10/100BaseTX
Fa0/2                      connected    10         a-full   a-100 10/100BaseTX
Fa0/3                      notconnect   10           auto    auto 10/100BaseTX
Fa0/4                      notconnect   10           auto    auto 10/100BaseTX
Fa0/5                      connected    20         a-full   a-100 10/100BaseTX
Fa0/6                      connected    20         a-full   a-100 10/100BaseTX
Fa0/7                      notconnect   20           auto    auto 10/100BaseTX
Fa0/8                      notconnect   20           auto    auto 10/100BaseTX
Fa0/9                      notconnect   1            auto    auto 10/100BaseTX
Fa0/10                     connected    trunk      a-full   a-100 10/100BaseTX
Fa0/11                     notconnect   1            auto    auto 10/100BaseTX
Fa0/12                     notconnect   1            auto    auto 10/100BaseTX
Fa0/13                     notconnect   1            auto    auto 10/100BaseTX
Fa0/14                     notconnect   1            auto    auto 10/100BaseTX
Fa0/15                     notconnect   1            auto    auto 10/100BaseTX


SW1# show interfaces trunk
Port      Mode         Encapsulation  Status        Native vlan
Fa0/0     on           802.1q         trunking      1
Fa0/10    on           802.1q         trunking      1

Port      Vlans allowed on trunk
Fa0/0     1-1005
Fa0/10    1-1005

Port      Vlans allowed and active in management domain
Fa0/0     1,10,20
Fa0/10    1,10,20

Port      Vlans in spanning tree forwarding state and not pruned
Fa0/0     1,10,20
Fa0/10    1,10,20

SW2

  • Tambahkan database vlan 10 dan vlan 20 pada switch
SW2# vlan database
SW2(vlan)# vlan 10 name vlan10
VLAN 10 added:
    Name: vlan10

SW2(vlan)# vlan 20 name vlan20
VLAN 20 added:
    Name: vlan20

SW2(vlan)# exit
APPLY completed.
Exiting....
  • Setting mode trunk pada FastEthernet 0/0
SW2# configure terminal
SW2(config)# interface fastEthernet 0/0
SW2(config-if)# switchport trunk encapsulation dot1q
SW2(config-if)# switchport mode trunk
SW2(config-if)# no shutdown
SW2(config-if)# exit
  • Setting mode access pada FastEthernet 0/1 – 0/4 untuk vlan 10
SW2(config)# interface fastEthernet 0/1
SW2(config-if)# switchport mode access
SW2(config-if)# switchport access vlan 10
SW2(config-if)# no shutdown
SW2(config-if)# exit
  • Setting mode access pada FastEthernet 0/5 – 0/8 untuk vlan 20
SW2(config)# interface fastEthernet 0/5
SW2(config-if)# switchport mode access
SW2(config-if)# switchport access vlan 20
SW2(config-if)# no shutdown
SW2(config-if)# exit
  • Cek status vlan pada switch setelah di konfigurasi
SW2# show vlan-switch
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                Fa0/13, Fa0/14, Fa0/15
10   vlan10                           active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
20   vlan20                           active    Fa0/5, Fa0/6, Fa0/7, Fa0/8
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
10   enet  100010     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0


SW2# show interfaces status
Port    Name               Status       Vlan       Duplex Speed Type
Fa0/0   *** Unused for Lay connected    trunk      a-full   a-100 10/100BaseTX
Fa0/1   *** Unused for Lay connected    10         a-full   a-100 10/100BaseTX
Fa0/2                      notconnect   10           auto    auto 10/100BaseTX
Fa0/3                      notconnect   10           auto    auto 10/100BaseTX
Fa0/4                      notconnect   10           auto    auto 10/100BaseTX
Fa0/5                      connected    20         a-full   a-100 10/100BaseTX
Fa0/6                      notconnect   20           auto    auto 10/100BaseTX
Fa0/7                      notconnect   20           auto    auto 10/100BaseTX
Fa0/8                      notconnect   20           auto    auto 10/100BaseTX
Fa0/9                      notconnect   1            auto    auto 10/100BaseTX
Fa0/10                     notconnect   1            auto    auto 10/100BaseTX
Fa0/11                     notconnect   1            auto    auto 10/100BaseTX
Fa0/12                     notconnect   1            auto    auto 10/100BaseTX
Fa0/13                     notconnect   1            auto    auto 10/100BaseTX
Fa0/14                     notconnect   1            auto    auto 10/100BaseTX
Fa0/15                     notconnect   1            auto    auto 10/100BaseTX


SW2# show interfaces trunk
Port      Mode         Encapsulation  Status        Native vlan
Fa0/0     on           802.1q         trunking      1

Port      Vlans allowed on trunk
Fa0/0     1-1005

Port      Vlans allowed and active in management domain
Fa0/0     1,10,20

Port      Vlans in spanning tree forwarding state and not pruned
Fa0/0     1,10,20

Pengujian

  • Cek ip dhcp client pada PC3 untuk vlan 10 dan PC4 untuk vlan 20
  • PC3 dan PC4 berhasil mendapatkan IP dhcp dari router, dan berhasil terkoneksi ke internet

herdiana3389

A system administrator with skills in system administration, virtualization, linux, windows, networking, cloud computing, container, etc.